summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3a8afa65e1..3ace28bd25 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -589,11 +589,13 @@ to adapt the plain e-TeX source file to work with XeTeX and LuaTeX.")
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out  (assoc-ref outputs "out"))
                     (base (string-append out "/share/texmf-dist/web2c"))
-                    (mf   (string-append out "/share/texmf-dist/metafont/base")))
+                    (mf   (string-append out "/share/texmf-dist/metafont/")))
                (mkdir-p base)
                (mkdir-p mf)
                (install-file "build/mf.base" base)
-               (copy-recursively "base" mf)
+               (for-each (lambda (where)
+                           (copy-recursively where (string-append mf where)))
+                         (list "base" "misc" "config"))
                #t))))))
     (native-inputs
      `(("texlive-bin" ,texlive-bin)))