summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bqn.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/bqn.scm b/gnu/packages/bqn.scm
index 4ca9f48a0e..8aef8c6bcd 100644
--- a/gnu/packages/bqn.scm
+++ b/gnu/packages/bqn.scm
@@ -109,3 +109,17 @@ not need to be bootstrapped, based on an earlier Java implementation of APL by
 the same author.")
       (home-page "https://github.com/dzaima/BQN")
       (license license:expat))))
+
+(define bqn-sources
+  ;; Aside from dbqn above, the main bqn repository is used by other
+  ;; implementations as a "known good" set of sources. CBQN uses dbqn to
+  ;; generate an intermediate bytecode for its own compilation.
+    (let ((commit "e219af48401473a7bac49bdd8b89d69082cf5dd8"))
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+              (url "https://github.com/mlochbaum/BQN")
+              (commit commit)))
+        (file-name (git-file-name "bqn-sources" commit))
+        (sha256
+         (base32 "0r6pa9lscl2395g4xlvmg90vpdsjzhin4f1r0s7brymmpvmns2yc")))))