summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/dns.scm6
-rw-r--r--gnu/packages/patches/knot-test_net_shortwrite-ensure-connection.patch19
2 files changed, 2 insertions, 23 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 5b159bc656..0cf07853e0 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -807,7 +807,7 @@ Extensions} (DNSSEC).")
 (define-public knot
   (package
     (name "knot")
-    (version "3.0.0")
+    (version "3.0.1")
     (source
      (origin
        (method git-fetch)
@@ -816,9 +816,7 @@ Extensions} (DNSSEC).")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0fkvip7n5ihjfwnnivdc3jf44y8p85ifglvq7b0anxvj9cg1m78f"))
-       (patches
-        (search-patches "knot-test_net_shortwrite-ensure-connection.patch"))
+        (base32 "10mlzldxqvbaw78nghkr0s73rlbpz9wg16z14321xw2l9xfibkad"))
        (modules '((guix build utils)))
        (snippet
         '(begin
diff --git a/gnu/packages/patches/knot-test_net_shortwrite-ensure-connection.patch b/gnu/packages/patches/knot-test_net_shortwrite-ensure-connection.patch
deleted file mode 100644
index 8b57ec522e..0000000000
--- a/gnu/packages/patches/knot-test_net_shortwrite-ensure-connection.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-This patch duplicates upstream commit 4144d1e, which helps ensure the
-"test_net_shortwrite" test suite can succeed across all platforms by
-deepening the pending-connection queue of the server it creates from 0
-to 1.
-
-See the original report at
-https://gitlab.nic.cz/knot/knot-dns/-/issues/693
-
---- a/tests/contrib/test_net_shortwrite.c
-+++ b/tests/contrib/test_net_shortwrite.c
-@@ -88,7 +88,7 @@ int main(int argc, char *argv[])
-	int server = net_bound_socket(SOCK_STREAM, &addr, 0);
-	ok(server >= 0, "server: bind socket");
-
--	r = listen(server, 0);
-+	r = listen(server, 1);
-	ok(r == 0, "server: start listening");
-
-	struct sockaddr *sa = (struct sockaddr *)&addr;