summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/man.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 14aaa36ea1..1c1d82758b 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -146,8 +146,7 @@ a flexible and convenient way.")
                                  (substitute* file
                                    (("#! /bin/sh")
                                     (string-append "#!" (which "sh")))))
-                               (remove file-is-directory?
-                                       (find-files "src/tests" ".*"))))))
+                               (find-files "src/tests")))))
                (add-after 'unpack 'patch-absolute-paths
                  (lambda* (#:key inputs #:allow-other-keys)
                    (substitute* "src/man.c"
@@ -194,10 +193,7 @@ a flexible and convenient way.")
                    '("nroff" "eqn" "neqn" "tbl" "refer" "pic")))
            ;; At run time we should refer to GROFF-MINIMAL, not GROFF (the latter
            ;; pulls in Perl.)
-           #:disallowed-references (list groff)
-           #:modules '((guix build gnu-build-system)
-                       (guix build utils)
-                       (srfi srfi-1))))
+           #:disallowed-references (list groff)))
     (native-inputs
      (list pkg-config flex
            ;; Groff is needed at build time for troff, grops, soelim, etc.