summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crypto.scm10
-rw-r--r--gnu/packages/patches/hash-extender-test-suite.patch13
2 files changed, 4 insertions, 19 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index afe85ae497..f48ab50ca9 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -1075,8 +1075,8 @@ API.")
     (license license:asl2.0)))
 
 (define-public hash-extender
-  (let ((commit "9ecef26809a1ceea2a455f6f591b004298df551b")
-        (revision "1"))
+  (let ((commit "cb8aaee49f93e9c0d2f03eb3cafb429c9eed723d")
+        (revision "2"))
     (package
       (name "hash-extender")
       (version (git-version "0.0" revision commit))
@@ -1087,10 +1087,8 @@ API.")
                       (commit commit)))
                 (sha256
                  (base32
-                  "0fqy3d559zgf71w39py0931d8na0ylils45r8zs6r79wgr6qn78c"))
-                (file-name (git-file-name name version))
-                (patches
-                  (search-patches "hash-extender-test-suite.patch"))))
+                  "1fj118566hr1wv03az2w0iqknazsqqkak0mvlcvwpgr6midjqi9b"))
+                (file-name (git-file-name name version))))
       (build-system gnu-build-system)
       (arguments
        `(#:phases
diff --git a/gnu/packages/patches/hash-extender-test-suite.patch b/gnu/packages/patches/hash-extender-test-suite.patch
deleted file mode 100644
index 59de52dad4..0000000000
--- a/gnu/packages/patches/hash-extender-test-suite.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Make the test suite exit with a non-zero exit code if some tests failed.
-Pull request pending upstream: https://github.com/iagox86/hash_extender/pull/13
---- a/test.c
-+++ b/test.c
-@@ -79,5 +79,9 @@ void test_report(void)
-     printf("TESTS PASSED: %d / %d [%2.4f%%]\n", tests_passed, tests_run, 100 * (float)tests_passed / tests_run);
-     printf("--------------------------------------------------------------------------------\n");
-   }
-+
-+  if (tests_passed != tests_run) {
-+      exit(1);
-+  }
- }