summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7f1aedaa19..f75b61a59a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -498,6 +498,14 @@ files from LOCATIONS with expected checksum HASH.  CODE is not currently in use.
                                   source "/texlive-scripts/source/")
                                  scripts)
 
+               ;; Patch them.
+               (let ((dirs (map dirname (list (which "sed") (which "awk")))))
+                 (with-directory-excursion scripts
+                   (substitute* '("mktexpk" "mktexmf" "mktexlsr")
+                     (("^version=" m)
+                      (format #false "PATH=\"~{~a:~}$PATH\"; export PATH~%~a"
+                              dirs m)))))
+
                ;; Make sure that fmtutil can find its Perl modules.
                (substitute* (string-append scripts "/fmtutil.pl")
                  (("\\$TEXMFROOT/")