summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index f950b9b844..9ef5178598 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1336,6 +1336,30 @@ required to analyse accounting using multiple different axes.")
 analytic accounts on invoice line.")
     (license license:gpl3+)))
 
+(define-public trytond-analytic-purchase
+  (package
+    (name "trytond-analytic-purchase")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_analytic_purchase" version))
+       (sha256
+        (base32 "1yx3w3p98y11qw99jy02kal9393y6jpxazsfcznsffgigw2vl3y6"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "analytic_purchase"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-analytic-account" ,trytond-analytic-account)
+       ("trytond-analytic-invoice" ,trytond-analytic-invoice)
+       ("trytond-purchase" ,trytond-purchase)))
+    (home-page "https://docs.tryton.org/projects/modules-analytic-purchase")
+    (synopsis "Tryton module to add analytic accounting on purchase")
+    (description "The @emph{Analytic Purchase} Tryton module allows to set
+analytic accounts on purchase line.")
+    (license license:gpl3+)))
+
 (define-public trytond-company
   (package
     (name "trytond-company")