summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/pascal.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/pascal.scm b/gnu/packages/pascal.scm
index 74daf058ca..e199f981a1 100644
--- a/gnu/packages/pascal.scm
+++ b/gnu/packages/pascal.scm
@@ -93,14 +93,15 @@
        ("zlib" ,zlib)))
     (native-inputs
      ;; FPC is built with FPC, so we need bootstrap binaries.
-     `(("fpc-binary"
-        (match ,(or (%current-target-system)
-                    (%current-system))
-          ("i686-linux" ,fpc-bootstrap-i386)
-          ;;("powerpc64le-linux" ,fpc-bootstrap-ppc64le)
-          ;;("powerpc-linux" ,fpc-bootstrap-ppc)
-          ("x86_64-linux" ,fpc-bootstrap-x86_64)
-          (arch (error "fpc arch not yet supported in guix" arch))))))
+     `(("fpc-binary" ,(match (or (%current-target-system)
+                                 (%current-system))
+                       ("i686-linux" fpc-bootstrap-i386)
+                       ;;("powerpc64le-linux" fpc-bootstrap-ppc64le)
+                       ;;("powerpc-linux" fpc-bootstrap-ppc)
+                       ("x86_64-linux" fpc-bootstrap-x86_64)
+                       ;; XXX: Wrong, but innocuous so long
+                       ;; `supported-systems' is kept in sync.
+                       (_ fpc-bootstrap-x86_64)))))
     (arguments
      `(#:tests? #f ; no tests available
        #:phases