summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 55a94428ed..c761652087 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3795,8 +3795,9 @@ devices that can inject events directly into the input subsystem.")
      `(("libevdev" ,libevdev)
        ("yaml-cpp" ,yaml-cpp)))
     (arguments
-     `(#:make-flags (list "CC=gcc" "CXX=g++"
-                          (string-append "PREFIX=" (assoc-ref %outputs "out")))
+     `(#:make-flags (list ,(string-append "CC=" (cc-for-target))
+                          ,(string-append "CXX=" (cxx-for-target))
+                          (string-append "PREFIX=" %output))
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'fix-libevdev-path
@@ -3807,9 +3808,9 @@ devices that can inject events directly into the input subsystem.")
                   (string-append libevdev "/include/libevdev-1.0")))
                #t)))
          ;; No configure script
-         (delete 'configure)
-         ;; No target 'check'
-         (delete 'check))))
+         (delete 'configure))
+       ;; No tests are included.
+       #:tests? #f))
     (synopsis "Tap for one key, hold for another")
     (description
      "Dual Function Keys is a plugin for @code{interception-tools} that allows