summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/ffmpeg-remove-compressed_ten_bit_format.patch43
-rw-r--r--gnu/packages/video.scm6
3 files changed, 2 insertions, 48 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a97e988add..1f0051364f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1259,7 +1259,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/ffmpeg-jami-pipewiregrab-source-filter.patch	\
   %D%/packages/patches/ffmpeg-jami-remove-mjpeg-log.patch	\
   %D%/packages/patches/ffmpeg-jami-screen-sharing-x11-fix.patch	\
-  %D%/packages/patches/ffmpeg-remove-compressed_ten_bit_format.patch	\
   %D%/packages/patches/ffmpeg-4-binutils-2.41.patch	\
   %D%/packages/patches/fifengine-boost-compat.patch		\
   %D%/packages/patches/fifengine-python-3.9-compat.patch	\
diff --git a/gnu/packages/patches/ffmpeg-remove-compressed_ten_bit_format.patch b/gnu/packages/patches/ffmpeg-remove-compressed_ten_bit_format.patch
deleted file mode 100644
index 3eac98d1f9..0000000000
--- a/gnu/packages/patches/ffmpeg-remove-compressed_ten_bit_format.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 031f1561cd286596cdb374da32f8aa816ce3b135 Mon Sep 17 00:00:00 2001
-From: Christopher Degawa <christopher.degawa@intel.com>
-Date: Thu, 20 Oct 2022 22:55:27 -0500
-Subject: [PATCH] avcodec/libsvtav1: remove compressed_ten_bit_format and
- simplify alloc_buffer
-
-compressed_ten_bit_format has been deprecated upstream and has no effect
-and can be removed. Plus, technically it was never used in the first place
-since it would require the app (ffmpeg) to set it and do additional
-processing of the input frames.
-
-Also simplify alloc_buffer by removing calculations relating to the
-non-existant processing.
-
-Signed-off-by: Christopher Degawa <christopher.degawa@intel.com>
----
- libavcodec/libsvtav1.c | 10 +++-------
- 1 file changed, 3 insertions(+), 7 deletions(-)
-
-diff --git a/libavcodec/libsvtav1.c b/libavcodec/libsvtav1.c
-index 2f5634cee0241..28da206cf8512 100644
---- a/libavcodec/libsvtav1.c
-+++ b/libavcodec/libsvtav1.c
-@@ -124,16 +124,12 @@ static int svt_print_error(void *log_ctx, EbErrorType err,
- 
- static int alloc_buffer(EbSvtAv1EncConfiguration *config, SvtContext *svt_enc)
- {
--    const int    pack_mode_10bit =
--        (config->encoder_bit_depth > 8) && (config->compressed_ten_bit_format == 0) ? 1 : 0;
--    const size_t luma_size_8bit  =
--        config->source_width * config->source_height * (1 << pack_mode_10bit);
--    const size_t luma_size_10bit =
--        (config->encoder_bit_depth > 8 && pack_mode_10bit == 0) ? luma_size_8bit : 0;
-+    const size_t luma_size = config->source_width * config->source_height *
-+        (config->encoder_bit_depth > 8 ? 2 : 1);
- 
-     EbSvtIOFormat *in_data;
- 
--    svt_enc->raw_size = (luma_size_8bit + luma_size_10bit) * 3 / 2;
-+    svt_enc->raw_size = luma_size * 3 / 2;
- 
-     // allocate buffer for in and out
-     svt_enc->in_buf           = av_mallocz(sizeof(*svt_enc->in_buf));
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 659c8cc06b..1fd0efbf90 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1923,16 +1923,14 @@ audio/video codec library.")
 (define-public ffmpeg-4
   (package
     (inherit ffmpeg-5)
-    (version "4.4.2")
+    (version "4.4.5")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "14xadxm1yaamp216nq09xwasxg5g133v86dbb33mdg5di1zrlhdg"))
-             (patches (search-patches "ffmpeg-remove-compressed_ten_bit_format.patch"
-                                      "ffmpeg-4-binutils-2.41.patch"))))
+               "01xb2vj4n52fv2y56n5ifirgzlg16qbgfg98f6ifbbhm6l6lwlgr"))))
     (inputs (modify-inputs (package-inputs ffmpeg)
               (replace "sdl2" sdl2-2.0)))
     (arguments