summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2d95421472..905a0b914e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13300,32 +13300,33 @@ automatically using existing List-ID headers in your mu database.  Just press
 automatically discovered and presented in recency order.")
       (license license:gpl3+))))
 
-(define-public emacs-mu4e-patch
+(define-public emacs-message-view-patch
   (let ((commit "522da46c1653b1cacc79cde91d6534da7ae9517d")
         (revision "1"))
     (package
-      (name "emacs-mu4e-patch")
+      (name "emacs-message-view-patch")
       (version (git-version "0.1.0" revision commit))
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
-                      (url "https://github.com/seanfarley/mu4e-patch")
+                      (url "https://github.com/seanfarley/message-view-patch")
                       (commit commit)))
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
                   "10lzf3b70pk6rzdrgx0ww0gc94v0ydh9zj1gbsa20xw27ds7hmfn"))))
       (build-system emacs-build-system)
-      (propagated-inputs
-       (list mu))
       (home-page "https://github.com/seanfarley/mu4e-patch")
-      (synopsis "Colorize patch-like emails in mu4e")
+      (synopsis "Colorize patch-like emails in mu4e or gnus")
       (description
-        "Extension for mu4e to colorize patch-like emails with diff-mode.
+       "Extension for mu4e or gnus to colorize patch-like emails with diff-mode.
 This is based on Frank Terbeck's @code{gnus-article-treat-patch.el} but has
-been adapted to work with mu4e.")
+been adapted to also work with mu4e.")
       (license license:gpl3+))))
 
+(define-public emacs-mu4e-patch
+  (deprecated-package "emacs-mu4e-patch" emacs-message-view-patch))
+
 (define-public emacs-pretty-mode
   (package
     (name "emacs-pretty-mode")