summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/openbox.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/openbox.scm b/gnu/packages/openbox.scm
index d89b8c1024..36270aff67 100644
--- a/gnu/packages/openbox.scm
+++ b/gnu/packages/openbox.scm
@@ -52,14 +52,7 @@
     (propagated-inputs `(("python2-pyxdg" ,python2-pyxdg)))
     (inputs `(("imlib2" ,imlib2)
               ("libxml2" ,libxml2)
-
-              ;; Librsvg, an optional dependency, depends on Rust, which is
-              ;; well supported only on x86_64.  Thus, remove it on other
-              ;; architectures.
-              ,@(if (target-x86-64?)
-                    `(("librsvg" ,librsvg))
-                    '())
-
+              ("librsvg" ,(librsvg-for-system))
               ("libsm" ,libsm)
               ("libxcursor" ,libxcursor)
               ("libxinerama" ,libxinerama)