summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm20
1 files changed, 18 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index a295974d4e..dae8770a27 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1025,7 +1025,7 @@ write native speed custom Git applications in any language with bindings.")
 (define-public libgit2-1.8
   (package
     (inherit libgit2-1.7)
-    (version "1.8.0")
+    (version "1.8.1")
     (source (origin
               (inherit (package-source libgit2-1.7))
               (uri (git-reference
@@ -1034,7 +1034,23 @@ write native speed custom Git applications in any language with bindings.")
               (file-name (git-file-name "libgit2" version))
               (sha256
                (base32
-                "0f0vqml6fp94z07xkpim2sdj2xvpxnsrwbm1q1dibx4vqjd7mh3q"))))))
+                "1mh55804cvxl2cyl4clinajzgfn3zmlhacnv1pdvdj4w6z2w4si7"))
+	      (snippet
+               '(begin
+                  (for-each delete-file-recursively
+                            '("deps/chromium-zlib"
+                              "deps/llhttp"
+                              "deps/ntlmclient"
+                              "deps/pcre"
+                              "deps/winhttp"
+                              "deps/zlib"))))))
+    (arguments (substitute-keyword-arguments (package-arguments libgit2-1.7)
+                 ((#:configure-flags flags #~(list))
+                  #~(map (lambda (arg)
+                           (if (string= "-DUSE_HTTP_PARSER=system" arg)
+                               "-DUSE_HTTP_PARSER=http-parser"
+                               arg))
+                         #$flags))))))
 
 (define-public libgit2-1.6
   (package