summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 76f97f7e8a..481037066b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -841,11 +841,8 @@ ext3 or ext4 partition.")
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (bin (string-append out "/bin")))
-               (mkdir-p bin)
-               (copy-file "zerofree"
-                          (string-append bin "/zerofree"))
-               (chmod (string-append bin "/zerofree")
-                      #o555)
+               (chmod "zerofree" #o555)
+               (install-file "zerofree" bin)
                #t))))
        #:tests? #f))                    ; no tests
     (inputs `(("libext2fs" ,e2fsprogs)))