summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9b2c0ace7f..282d81b310 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -274,6 +274,15 @@ large scale eigenvalue problems.")
     (license (license:non-copyleft "file://COPYING"
                                 "See COPYING in the distribution."))))
 
+(define-public arpack-ng-openmpi
+  (package (inherit arpack-ng)
+    (name "arpack-ng-openmpi")
+    (inputs
+     `(("mpi" ,openmpi)
+       ,@(package-inputs arpack-ng)))
+    (arguments `(#:configure-flags '("--enable-mpi")))
+    (synopsis "Fortran subroutines for solving eigenvalue problems with MPI")))
+
 (define-public lapack
   (package
     (name "lapack")