summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm1
-rw-r--r--gnu/packages/databases.scm2
-rw-r--r--gnu/packages/python-xyz.scm20
3 files changed, 4 insertions, 19 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 1d9a4413f1..90a6fba2b9 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1328,7 +1328,6 @@ and many external plugins.")
                 (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)))))))
     (propagated-inputs
      (modify-inputs (package-propagated-inputs python-pytest)
-       (replace "python-pluggy" python-pluggy-next)
        (replace "python-toml" python-tomli)))))
 
 (define-public python-pytest-bootstrap
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index b37bb255a4..cd3562bb8c 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -5166,7 +5166,7 @@ mechanism of @code{dogpile}.")
            python-jinja2
            python-mergedeep
            python-pint
-           python-pluggy-next
+           python-pluggy
            python-pyyaml
            python-uvicorn))
     (native-inputs
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 373ddc69e3..6cfefc93b2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15582,36 +15582,22 @@ library as well as on the command line.")
 (define-public python-pluggy
   (package
    (name "python-pluggy")
-   (version "0.13.1")
+   (version "1.0.0")
    (source
     (origin
      (method url-fetch)
      (uri (pypi-uri "pluggy" version))
      (sha256
       (base32
-       "1c35qyhvy27q9ih9n899f3h4sdnpgq027dbiilly2qb5cvgarchm"))))
+       "0n8iadlas2z1b4h0fc73b043c7iwfvx9rgvqm1azjmffmhxkf922"))))
    (build-system python-build-system)
-   (native-inputs
-    (list python-setuptools-scm))
+   (native-inputs (list python-setuptools-scm))
    (synopsis "Plugin and hook calling mechanism for Python")
    (description "Pluggy is an extraction of the plugin manager as used by
 Pytest but stripped of Pytest specific details.")
    (home-page "https://pypi.org/project/pluggy/")
    (license license:expat)))
 
-;;; TODO: Make this the default python-pluggy in the next rebuild cycle.
-(define-public python-pluggy-next
-  (package
-   (inherit python-pluggy)
-   (version "1.0.0")
-   (source
-    (origin
-     (method url-fetch)
-     (uri (pypi-uri "pluggy" version))
-     (sha256
-      (base32
-       "0n8iadlas2z1b4h0fc73b043c7iwfvx9rgvqm1azjmffmhxkf922"))))))
-
 (define-public python-plumbum
   (package
     (name "python-plumbum")