summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gsasl.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/gsasl.scm b/gnu/packages/gsasl.scm
index fb5712a7b0..8b5b2b59f6 100644
--- a/gnu/packages/gsasl.scm
+++ b/gnu/packages/gsasl.scm
@@ -83,10 +83,12 @@ SMTP/IMAP servers. GSS consists of a library and a manual.")
    (build-system gnu-build-system)
    (inputs `(("libidn" ,libidn)
              ("libntlm" ,libntlm)
-             ("gnutls" ,gnutls)
              ("gss" ,gss)
-             ("zlib" ,guix:zlib)
-             ))
+             ("zlib" ,guix:zlib)))
+   (propagated-inputs
+    ;; Propagate GnuTLS because libgnutls.la reads `-lnettle', and Nettle is a
+    ;; propagated input of GnuTLS.
+    `(("gnutls" ,gnutls)))
    (synopsis "Simple Authentication and Security Layer library")
    (description
     "GNU SASL is an implementation of the Simple Authentication and Security