summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bootstrap.scm14
-rw-r--r--gnu/packages/linux-initrd.scm41
-rw-r--r--gnu/packages/linux.scm10
-rw-r--r--gnu/packages/make-bootstrap.scm14
4 files changed, 39 insertions, 40 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index a1d4c7fc67..11f54ad051 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -70,14 +70,13 @@
                      (boot url-fetch))
                     (else orig-method))))))
 
-(define (package-from-tarball name* source* program-to-test description*)
-  "Return a package that correspond to the extraction of SOURCE*.
-PROGRAM-TO-TEST is a program to run after extraction of SOURCE*, to
+(define (package-from-tarball name source program-to-test description)
+  "Return a package that correspond to the extraction of SOURCE.
+PROGRAM-TO-TEST is a program to run after extraction of SOURCE, to
 check whether everything is alright."
   (package
-    (name name*)
+    (name name)
     (version "0")
-    (source #f)
     (build-system trivial-build-system)
     (arguments
      `(#:guile ,%bootstrap-guile
@@ -101,8 +100,9 @@ check whether everything is alright."
     (inputs
      `(("tar" ,(search-bootstrap-binary "tar" (%current-system)))
        ("xz"  ,(search-bootstrap-binary "xz" (%current-system)))
-       ("tarball" ,(bootstrap-origin (source* (%current-system))))))
-    (synopsis description*)
+       ("tarball" ,(bootstrap-origin (source (%current-system))))))
+    (source #f)
+    (synopsis description)
     (description #f)
     (home-page #f)
     (license #f)))
diff --git a/gnu/packages/linux-initrd.scm b/gnu/packages/linux-initrd.scm
index ed30fa56b1..0134e89da8 100644
--- a/gnu/packages/linux-initrd.scm
+++ b/gnu/packages/linux-initrd.scm
@@ -212,28 +212,27 @@ list of Guile module names to be embedded in the initrd."
                     (and (zero? (system* gzip "--best" "initrd"))
                          (rename-file "initrd.gz" "initrd")))))))))
 
-  (let ((name* name))
-    (package
-      (name name*)
-      (version "0")
-      (source #f)
-      (build-system trivial-build-system)
-      (arguments `(#:modules ((guix build utils))
-                   #:builder ,builder))
-      (inputs `(("guile" ,guile)
-                ("cpio" ,cpio)
-                ("gzip" ,gzip)
-                ("modules" ,(module-package modules))
-                ("modules/compiled" ,(compiled-module-package modules))
-                ,@(if linux
-                      `(("linux" ,linux))
-                      '())))
-      (synopsis "An initial RAM disk (initrd) for the Linux kernel")
-      (description
-       "An initial RAM disk (initrd), really a gzipped cpio archive, for use by
+  (package
+    (name name)
+    (version "0")
+    (source #f)
+    (build-system trivial-build-system)
+    (arguments `(#:modules ((guix build utils))
+                           #:builder ,builder))
+    (inputs `(("guile" ,guile)
+              ("cpio" ,cpio)
+              ("gzip" ,gzip)
+              ("modules" ,(module-package modules))
+              ("modules/compiled" ,(compiled-module-package modules))
+              ,@(if linux
+                    `(("linux" ,linux))
+                    '())))
+    (synopsis "An initial RAM disk (initrd) for the Linux kernel")
+    (description
+     "An initial RAM disk (initrd), really a gzipped cpio archive, for use by
 the Linux kernel.")
-      (license gpl3+)
-      (home-page "http://www.gnu.org/software/guix/"))))
+    (license gpl3+)
+    (home-page "http://www.gnu.org/software/guix/")))
 
 (define-public qemu-initrd
   (expression->initrd
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 469ccc552c..1402f05974 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -65,7 +65,7 @@
          version "-gnu.tar.xz")))
 
 (define-public linux-libre-headers
-  (let* ((version* "3.3.8")
+  (let* ((version "3.3.8")
          (build-phase
           (lambda (arch)
             `(lambda _
@@ -85,10 +85,10 @@
                         (string-append out
                                        "/include/config/kernel.release")
                       (lambda (p)
-                        (format p "~a-default~%" ,version*))))))))
+                        (format p "~a-default~%" ,version))))))))
    (package
     (name "linux-libre-headers")
-    (version version*)
+    (version version)
     (source (origin
              (method url-fetch)
              (uri (linux-libre-urls version))
@@ -145,7 +145,7 @@
     (license gpl2+)))
 
 (define-public linux-libre
-  (let* ((version* "3.11")
+  (let* ((version "3.11")
          (build-phase
           '(lambda* (#:key system #:allow-other-keys #:rest args)
              (let ((arch (car (string-split system #\-))))
@@ -185,7 +185,7 @@
                                "modules_install"))))))
    (package
     (name "linux-libre")
-    (version version*)
+    (version version)
     (source (origin
              (method url-fetch)
              (uri (linux-libre-urls version))
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 5dc7387e92..8c148f7086 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -451,15 +451,15 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
   ;; A statically-linked Guile that is relocatable--i.e., it can search
   ;; .scm and .go files relative to its installation directory, rather
   ;; than in hard-coded configure-time paths.
-  (let* ((patches* (cons* (search-patch "guile-relocatable.patch")
-                          (search-patch "guile-default-utf8.patch")
-                          (search-patch "guile-linux-syscalls.patch")
-                          (origin-patches (package-source guile-2.0))))
-         (source*  (origin (inherit (package-source guile-2.0))
-                     (patches patches*)))
+  (let* ((patches (cons* (search-patch "guile-relocatable.patch")
+                         (search-patch "guile-default-utf8.patch")
+                         (search-patch "guile-linux-syscalls.patch")
+                         (origin-patches (package-source guile-2.0))))
+         (source  (origin (inherit (package-source guile-2.0))
+                    (patches patches)))
          (guile (package (inherit guile-2.0)
                   (name (string-append (package-name guile-2.0) "-static"))
-                  (source source*)
+                  (source source)
                   (synopsis "Statically-linked and relocatable Guile")
                   (propagated-inputs
                    `(("bdw-gc" ,libgc)