summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
new file mode 100644
index 0000000000..b011606c24
--- /dev/null
+++ b/gnu/packages/audio.scm
@@ -0,0 +1,57 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages audio)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix git-download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages databases)
+  #:use-module (gnu packages linux))
+
+(define-public jack-1
+  (package
+    (name "jack")
+    (version "0.124.1")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "http://jackaudio.org/downloads/jack-audio-connection-kit-"
+                   version
+                   ".tar.gz"))
+             (sha256
+              (base32
+               "1mk1wnx33anp6haxfjjkfhwbaknfblsvj35nxvz0hvspcmhdyhpb"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("bdb" ,bdb)
+       ("libuuid" ,util-linux)))
+    (home-page "http://jackaudio.org/")
+    (synopsis "JACK audio connection kit")
+    (description
+     "JACK is a low-latency audio server.  It can connect a number of
+different applications to an audio device, as well as allowing them to share
+audio between themselves.  JACK is different from other audio server efforts
+in that it has been designed from the ground up to be suitable for
+professional audio work.  This means that it focuses on two key areas:
+synchronous execution of all clients, and low latency operation.")
+    ;; Most files are licensed under the GPL. However, the libjack/ tree is
+    ;; licensed under the LGPL in order to allow for proprietary usage.
+    (license '(license:gpl2+ license:lgpl2.1+))))