summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/autotools.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 3d5c85463f..e45f53d927 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -307,4 +307,13 @@ complexity of working with shared libraries across platforms.")
 
     (native-inputs `(("automake" ,automake)      ;some tests rely on 'aclocal'
                      ("autoconf" ,(autoconf-wrapper)) ;others on 'autom4te'
-                     ,@(package-native-inputs libtool)))))
+                     ,@(package-native-inputs libtool)))
+
+    (arguments
+     ;; XXX: There are test failures on mips64el-linux starting from 2.4.4:
+     ;; <http://hydra.gnu.org/build/181662>.
+     (if (string-prefix? "mips64el"
+                         (or (%current-target-system) (%current-system)))
+         `(#:tests? #f
+           ,@(package-arguments libtool))
+         (package-arguments libtool)))))