summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 12 insertions, 14 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 396c14d892..47483a89a0 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -42526,15 +42526,14 @@ compliant email address validation.")
         (base32
          "0yvmjpywfyypfr17kxiwy6ssykgv8nmcdhfakas6548pfn8a9fiv"))))
     (arguments
-     `(#:cargo-inputs
+     `(#:skip-build? #t
+       #:cargo-inputs
        (("rust-error-chain" ,rust-error-chain-0.12)
         ("rust-idna" ,rust-idna-0.2)
         ("rust-lazy-static" ,rust-lazy-static-1)
         ("rust-native-tls" ,rust-native-tls-0.2)
         ("rust-regex" ,rust-regex-1)
-        ("rust-url" ,rust-url-2))
-       #:cargo-development-inputs
-       (("rust-rspec" ,rust-rspec-1))))))
+        ("rust-url" ,rust-url-2))))))
 
 (define-public rust-pulldown-cmark-0.8
   (package
@@ -46379,25 +46378,24 @@ wildcard segments")
 (define-public rust-rspec-1
   (package
     (name "rust-rspec")
-    (version "1.0.0-beta.4")
+    (version "1.0.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "rspec" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1abfzwkbxlwahb243k8d3fp6i135lx1aqmbfl79w9zlpng182ndk"))))
+        (base32 "02hfwxqjdc39ygnjysvn5qz343fahmwm16rxvxayh403d5y9wf49"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:skip-build? #t ;; TODO unpackaged dev-dependencies
-       #:cargo-inputs
-       (("rust-colored" ,rust-colored-1)
+     `(#:cargo-inputs
+       (("rust-clippy" ,rust-clippy-0.0.153)
+        ("rust-colored" ,rust-colored-2)
         ("rust-derive-new" ,rust-derive-new-0.5)
-        ("rust-derive-builder" ,rust-derive-builder-0.5)
-        ("rust-expectest" ,rust-expectest-0.9)
-        ("rust-rayon" ,rust-rayon-0.8))
-       #:cargo-development-inputs
-       (("rust-clippy" ,rust-clippy-0.0)))) ;; requires 0.0.153
+        ("rust-derive-builder" ,rust-derive-builder-0.9)
+        ("rust-expectest" ,rust-expectest-0.12)
+        ("rust-rayon" ,rust-rayon-1)
+        ("rust-time" ,rust-time-0.2))))
     (home-page "https://github.com/rust-rspec/rspec")
     (synopsis "Write Rspec-like tests with stable rust")
     (description "This package helps writing Rspec-like tests with stable