summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index c59601250a..d4d652bd1a 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -996,6 +996,26 @@ the unsightly mess of C<no strict> or typeglobs lying about where just anyone
 can see them.")
     (license (package-license perl))))
 
+(define-public perl-sub-uplevel
+  (package
+    (name "perl-sub-uplevel")
+    (version "0.24")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/D/DA/DAGOLDEN/"
+                           "Sub-Uplevel-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1yzxqsim8vpavzqm2wfksh8dpmy6qbr9s3hdqqicp38br3lzd4qg"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Sub-Uplevel")
+    (synopsis "Apparently run a function in a higher stack frame")
+    (description "Like Tcl's uplevel() function, but not quite so dangerous.
+The idea is just to fool caller().  All the really naughty bits of Tcl's
+uplevel() are avoided.")
+    (license (package-license perl))))
+
 (define-public perl-sys-cpu
   (package
     (name "perl-sys-cpu")