summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/avidemux-install-to-lib.patch24
-rw-r--r--gnu/packages/video.scm5
2 files changed, 27 insertions, 2 deletions
diff --git a/gnu/packages/patches/avidemux-install-to-lib.patch b/gnu/packages/patches/avidemux-install-to-lib.patch
new file mode 100644
index 0000000000..64c9213052
--- /dev/null
+++ b/gnu/packages/patches/avidemux-install-to-lib.patch
@@ -0,0 +1,24 @@
+Patch by Andreas Enge to force installation of libraries into lib
+independently of the architecture, instead of lib32 or lib64.
+On x86_64, the C library path coded in CMAKE_C_IMPLICIT_LINK_DIRECTORIES 
+contains a library (jack) installed into lib64, which forces lib64
+for avidemux with the original code.
+
+diff -u -r avidemux_2.6.8.orig/cmake/admInstallDir.cmake avidemux_2.6.8/cmake/admInstallDir.cmake
+--- avidemux_2.6.8.orig/cmake/admInstallDir.cmake	2014-03-12 07:15:23.000000000 +0100
++++ avidemux_2.6.8/cmake/admInstallDir.cmake	2015-07-26 14:31:10.418459984 +0200
+@@ -16,13 +16,7 @@
+                 MESSAGE(STATUS "No install dir provided, using /usr/local")
+         ENDIF(NOT AVIDEMUX_INSTALL_DIR )
+         SET(AVIDEMUX_BIN_DIR ${AVIDEMUX_INSTALL_DIR}/bin)
+-        IF(CMAKE_C_IMPLICIT_LINK_DIRECTORIES MATCHES "\\/lib64([; ]|$)")
+-                SET(AVIDEMUX_RELATIVE_LIB_DIR lib64)
+-        ELSEIF(CMAKE_C_IMPLICIT_LINK_DIRECTORIES MATCHES "\\/lib32([; ]|$)")
+-                SET(AVIDEMUX_RELATIVE_LIB_DIR lib32)
+-        ELSE(CMAKE_C_IMPLICIT_LINK_DIRECTORIES MATCHES "\\/lib64([; ]|$)")
+-                SET(AVIDEMUX_RELATIVE_LIB_DIR lib)
+-        ENDIF(CMAKE_C_IMPLICIT_LINK_DIRECTORIES MATCHES "\\/lib64([; ]|$)")
++        SET(AVIDEMUX_RELATIVE_LIB_DIR lib)
+         SET(AVIDEMUX_LIB_DIR ${AVIDEMUX_INSTALL_DIR}/${AVIDEMUX_RELATIVE_LIB_DIR})
+ ENDIF(WIN32)
+ SET(AVIDEMUX_INCLUDE_DIR ${AVIDEMUX_INSTALL_DIR}/include)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6ebd7787e1..c57c6c6700 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1090,7 +1090,8 @@ for use with HTML5 video.")
                    version ".tar.gz"))
              (sha256
               (base32
-               "10p60wjkzf1bxqcb6i7bx4hbqy3vqg598p3l9lc4v2c9b8iqr682"))))
+               "10p60wjkzf1bxqcb6i7bx4hbqy3vqg598p3l9lc4v2c9b8iqr682"))
+             (patches (map search-patch '("avidemux-install-to-lib.patch")))))
     (build-system cmake-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
@@ -1145,7 +1146,7 @@ for use with HTML5 video.")
             (lambda* (#:key inputs outputs #:allow-other-keys)
               (let*
                 ((out (assoc-ref outputs "out"))
-                 (lib (string-append out "/lib64"))
+                 (lib (string-append out "/lib"))
                  (top (getcwd))
                  (sdl (assoc-ref inputs "sdl"))
                  (build_component