summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fontutils.scm5
-rw-r--r--gnu/packages/ghostscript.scm11
-rw-r--r--gnu/packages/gtk.scm9
-rw-r--r--gnu/packages/imagemagick.scm4
-rw-r--r--gnu/packages/mp3.scm2
5 files changed, 18 insertions, 13 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 6ef09455b5..8e0980dd95 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -341,8 +341,9 @@ Font Format (WOFF).")
                           ("freetype" ,freetype)
                           ("libuuid" ,util-linux "lib")))
      (inputs
-      ;; We use to use 'gs-fonts' but they are not recognized by newer versions
-      ;; of Pango, causing many applications to fail to find fonts otherwise.
+      ;; We use to use 'font-ghostscript' but they are not recognized by newer
+      ;; versions of Pango, causing many applications to fail to find fonts
+      ;; otherwise.
       `(("font-dejavu" ,font-dejavu)))
      (native-inputs
       `(("gperf" ,gperf)
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 378ff6b37d..35e637648c 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -204,7 +204,7 @@ printing, and psresize, for adjusting page sizes.")
              "--enable-dynamic"
              "--disable-compile-inits"
              (string-append "--with-fontpath="
-                            (assoc-ref %build-inputs "gs-fonts")
+                            (assoc-ref %build-inputs "font-ghostscript")
                             "/share/fonts/type1/ghostscript")
 
              ,@(if (%current-target-system)
@@ -278,7 +278,7 @@ printing, and psresize, for adjusting page sizes.")
     (inputs
      `(("fontconfig" ,fontconfig)
        ("freetype" ,freetype)
-       ("gs-fonts" ,gs-fonts)
+       ("font-ghostscript" ,font-ghostscript)
        ("jbig2dec" ,jbig2dec)
        ("libjpeg" ,libjpeg-turbo)
        ("libpaper" ,libpaper)
@@ -343,9 +343,9 @@ architecture.")
    (license license:expat)
    (home-page (package-home-page ghostscript))))
 
-(define-public gs-fonts
+(define-public font-ghostscript
   (package
-   (name "gs-fonts")
+   (name "font-ghostscript")
    (version "8.11")
    (source (origin
             (method url-fetch)
@@ -384,6 +384,9 @@ Ghostscript.  It currently includes the 35 standard PostScript fonts.")
    (license license:gpl2)
    (home-page "https://sourceforge.net/projects/gs-fonts/")))
 
+(define-public gs-fonts
+  (deprecated-package "gs-fonts" font-ghostscript))
+
 (define-public libspectre
   (package
    (name "libspectre")
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 21e27d8597..bf4ce3b7b6 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -402,10 +402,11 @@ handling for GTK+-2.x.")
                  (add-after 'configure 'disable-layout-test
                    (lambda _
                      ;; This test requires that fontconfig uses bitmap fonts
-                     ;; such as "gs-fonts"; however providing such a package
-                     ;; alone is not enough, as the requirement comes from
-                     ;; deeper in the font stack.  Since this version of Pango
-                     ;; is only used for librsvg, simply disable the test.
+                     ;; such as "font-ghostscript"; however providing such a
+                     ;; package alone is not enough, as the requirement comes
+                     ;; from deeper in the font stack.  Since this version of
+                     ;; Pango is only used for librsvg, simply disable the
+                     ;; test.
                      (substitute* "tests/Makefile"
                        (("test-layout\\$\\(EXEEXT\\)") ""))
                      #t)))))))
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index 4f0ffcbcc6..f7cd961c05 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -235,12 +235,12 @@ script.")
              "--with-quantum-depth=16" ; required by Octave
              "--enable-quantum-library-names"
              (string-append "--with-gs-font-dir="
-                            (assoc-ref %build-inputs "gs-fonts")
+                            (assoc-ref %build-inputs "font-ghostscript")
                             "/share/fonts/type1/ghostscript"))))
     (inputs
      `(("graphviz" ,graphviz)
        ("ghostscript" ,ghostscript)
-       ("gs-fonts" ,gs-fonts)
+       ("font-ghostscript" ,font-ghostscript)
        ("lcms" ,lcms)
        ("libx11" ,libx11)
        ("libxml2" ,libxml2)
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index ff67d9e9e5..d59a133535 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -480,7 +480,7 @@ use with CD-recording software).")
             (patches (search-patches "ripperx-missing-file.patch"))))
    (build-system gnu-build-system)
    (propagated-inputs
-    `(("gs-fonts" ,gs-fonts)
+    `(("font-ghostscript" ,font-ghostscript)
       ("cdparanoia" ,cdparanoia)
       ("flac" ,flac)
       ("lame" ,lame)