summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 5577ad98e7..85faec6c47 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -255,7 +255,10 @@ without requiring the source code to be rewritten.")
   ;; in the `base' module, and thus changing it entails a full rebuild.
   (package
     (inherit guile-2.2)
-    (properties '((hidden? . #t)))          ;people should install 'guile-2.2'
+    (properties '((hidden? . #t)            ;people should install 'guile-2.2'
+                  (timeout . 72000)            ;20 hours
+                  (max-silent-time . 36000)))  ;10 hours (needed on ARM
+                                               ;  when heavily loaded)
     (replacement #f)))
 
 (define-public guile-next