summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm30
-rw-r--r--gnu/packages/linux.scm4
2 files changed, 12 insertions, 22 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 12e4de52d4..73bdf16ea5 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -524,7 +524,8 @@ change.  GNU make offers many powerful extensions over the standard utility.")
                                "binutils-2.37-file-descriptor-leak.patch"))))
    (build-system gnu-build-system)
    (arguments
-    `(#:configure-flags '(;; Add `-static-libgcc' to not retain a dependency
+    `(#:out-of-source? #t   ;recommended in the README
+      #:configure-flags '(;; Add `-static-libgcc' to not retain a dependency
                           ;; on GCC when bootstrapping.
                           "LDFLAGS=-static-libgcc"
 
@@ -543,7 +544,13 @@ change.  GNU make offers many powerful extensions over the standard utility.")
 
                           ;; Make sure 'ar' and 'ranlib' produce archives in a
                           ;; deterministic fashion.
-                          "--enable-deterministic-archives")))
+                          "--enable-deterministic-archives"
+
+                          "--enable-64-bit-bfd"
+                          "--enable-compressed-debug-sections=all"
+                          "--enable-lto"
+                          "--enable-separate-code"
+                          "--enable-threads")))
 
    (synopsis "Binary utilities: bfd gas gprof ld")
    (description
@@ -556,23 +563,6 @@ included.")
    (license gpl3+)
    (home-page "https://www.gnu.org/software/binutils/")))
 
-;;; TODO: Merge into binutils on the next world rebuild.
-(define-public binutils-next
-  (package/inherit binutils
-    (name "binutils-next")
-    (version "2.37")
-    (arguments
-     (substitute-keyword-arguments (package-arguments binutils)
-       ((#:out-of-source? _ #f)         ;recommended in the README
-        #t)
-       ((#:configure-flags flags)
-        `(cons* "--enable-64-bit-bfd"
-                "--enable-compressed-debug-sections=all"
-                "--enable-lto"
-                "--enable-separate-code"
-                "--enable-threads"
-                ,flags))))))
-
 ;; FIXME: ath9k-firmware-htc-binutils.patch do not apply on 2.34 because of a
 ;; big refactoring of xtensa-modules.c (commit 567607c11fbf7105 upstream).
 ;; Keep this version around until the patch is updated.
@@ -594,7 +584,7 @@ included.")
    (properties '())))
 
 (define-public binutils-gold
-  (package/inherit binutils-next
+  (package/inherit binutils
     (name "binutils-gold")
     (arguments
      (substitute-keyword-arguments (package-arguments binutils)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9bc32832c6..2789eae1aa 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8377,8 +8377,8 @@ platforms, it is not limited to resource-constrained systems.")
     ;; This variant of binutils is used for the 64 bit support needed to
     ;; assemble the `purgatory/arch/i386/compat_x86_64.S' program on i686-linux.
     (native-inputs (list (make-ld-wrapper "ld-wrapper"
-                                          #:binutils binutils-next)
-                         binutils-next))
+                                          #:binutils binutils)
+                         binutils))
     (home-page "https://projects.horms.net/projects/kexec/")
     (synopsis "Tools for booting directly into different kernels")
     (description "This package provides the @code{kexec} program and ancillary