summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/django.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 1a21e17262..6feca05f92 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -746,14 +746,9 @@ entries, photos, book chapters, or anything else.")
                 (which "env")))))
          (replace 'check
            (lambda*(#:key tests? #:allow-other-keys)
-             (or
-              (not tests?)
-              (begin
-                (setenv "PYTHONPATH"
-                        (string-append (getcwd) ":"
-                                       (getenv "PYTHONPATH")))
-                (setenv "DJANGO_SETTINGS_MODULE" "tests.settings")
-                (invoke "django-admin" "test" "tests"))))))))
+             (when tests?
+               (setenv "DJANGO_SETTINGS_MODULE" "tests.settings")
+               (invoke "django-admin" "test" "tests")))))))
     (native-inputs
      `(("python-django" ,python-django)))
     (propagated-inputs