summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crypto.scm2
-rw-r--r--gnu/packages/engineering.scm9
-rw-r--r--gnu/packages/tex.scm6
3 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index fe2cec045d..c545f47fcf 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -1118,7 +1118,7 @@ trivial to build for local use.  Portability is emphasized over performance.")
          ("automake" ,automake)
          ("libtool" ,libtool)))
       ;; WARNING: This package might need additional configure flags to run properly.
-      ;; See https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/libsecp256k1.
+      ;; See https://github.com/archlinux/svntogit-community/blob/packages/libsecp256k1/trunk/PKGBUILD.
       (synopsis "C library for EC operations on curve secp256k1")
       (description
        "Optimized C library for EC operations on curve secp256k1.
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index fc932ddb28..33c124a2ea 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1949,11 +1949,12 @@ parallel computing platforms.  It also supports serial execution.")
               (patches
                (list (origin
                        ;; Fix build with GCC 7.  Patch taken from Arch Linux:
-                       ;; https://git.archlinux.org/svntogit/community.git/tree/trunk?h=packages/freehdl
+                       ;; https://github.com/archlinux/svntogit-community/tree/packages/freehdl/trunk
                        (method url-fetch)
-                       (uri "https://git.archlinux.org/svntogit/community.git\
-/plain/trunk/build-fix.patch?h=packages/freehdl\
-&id=3bb90d64dfe6883e26083cd1fa96226d0d59175a")
+                       (uri (string-append "https://raw.githubusercontent.com"
+                                           "/archlinux/svntogit-community"
+                                           "/3bb90d64dfe6883e26083cd1fa96226d0d59175a"
+                                           "/trunk/build-fix.patch"))
                        (file-name "freehdl-c++-namespace.patch")
                        (sha256
                         (base32
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b404ca8ff1..3013b1e8b5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -252,9 +252,9 @@ files from LOCATIONS with expected checksum HASH.  CODE is not currently in use.
               (lambda (name revision hash)
                 (origin
                   (method url-fetch)
-                  (uri (string-append "https://git.archlinux.org/svntogit/packages.git"
-                                      "/plain/trunk/" name "?h=packages/texlive-bin"
-                                      "&id=" revision))
+                  (uri (string-append "https://raw.githubusercontent.com"
+                                      "/archlinux/svntogit-packages/" revision
+                                      "/repos/extra-x86_64/" name))
                   (file-name (string-append "texlive-bin-" name))
                   (sha256 (base32 hash)))))
              (arch-revision "49d7fe25e5ea63f136ebc20270c1d8fc9b00041c"))