summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/llvm.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 2b50b127c2..f854493281 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1592,14 +1592,16 @@ components which highly leverage existing libraries in the larger LLVM Project."
   "Return a LLD wrapper.  When LLD-AS-LD? is true, create a 'ld' symlink that
 points to 'lld'."
   (package
+    (inherit lld)
     (name (if lld-as-ld? "lld-as-ld-wrapper" "lld-wrapper"))
-    (version "0")
     (source #f)
-    (build-system trivial-build-system)
+    (native-inputs '())
     (inputs (list (make-ld-wrapper "ld.lld-wrapper" #:binutils lld
                                    #:linker "ld.lld")
                   (make-ld-wrapper "lld-wrapper" #:binutils lld #:linker
                                    "lld")))
+    (propagated-inputs '())
+    (build-system trivial-build-system)
     (arguments
      (list #:builder
            #~(let ((ld.lld (string-append #$(this-package-input
@@ -1616,9 +1618,7 @@ points to 'lld'."
     (synopsis "LLD linker wrapper")
     (description "This is a linker wrapper for LLD; like @code{ld-wrapper}, it
 wraps the linker to add any missing @code{-rpath} flags, and to detect any
-misuse of libraries outside of the store.")
-    (home-page "https://www.gnu.org/software/guix/")
-    (license license:gpl3+)))
+misuse of libraries outside of the store.")))
 
 ;;; A LLD wrapper suitable to use with -fuse-ld and GCC or with Clang.
 (define-public lld-wrapper