summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm5
-rw-r--r--gnu/packages/rust.scm4
2 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7aa7180f5e..29d75e2894 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3671,10 +3671,9 @@ diagrams.")
                              (system (or (%current-target-system)
                                          (%current-system))))
   ;; Since librsvg 2.50 depends on Rust, and Rust is only correctly supported
-  ;; on x86_64 and aarch64 so far, use the ancient C version on other
+  ;; on x86_64, aarch64 and riscv64 so far, use the ancient C version on other
   ;; platforms (FIXME).
-  (if (or (string-prefix? "x86_64-" system)
-          (string-prefix? "aarch64-" system))
+  (if (string-prefix? "x86_64-" system)
       librsvg
       librsvg-2.40))
 
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index d07f4ef10c..9af4ae2703 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -346,7 +346,9 @@ safety and thread safety guarantees.")
     ;; therefore the build process needs 8GB of RAM while building.
     ;; It may support i686 soon:
     ;; <https://github.com/thepowersgang/mrustc/issues/78>.
-    (supported-systems '("x86_64-linux" "aarch64-linux" "riscv64-linux"))
+    ;; XXX: The rust bootstrap is currently broken on aarch64 and riscv64,
+    ;; remove them until this is fixed.
+    (supported-systems '("x86_64-linux"))
 
     ;; Dual licensed.
     (license (list license:asl2.0 license:expat))))