summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ccache.scm11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnu/packages/ccache.scm b/gnu/packages/ccache.scm
index af06b741a7..af29cee565 100644
--- a/gnu/packages/ccache.scm
+++ b/gnu/packages/ccache.scm
@@ -30,7 +30,7 @@
 (define-public ccache
   (package
     (name "ccache")
-    (version "3.4.2")
+    (version "3.4.3")
     (source
      (origin
       (method url-fetch)
@@ -38,7 +38,7 @@
                           version ".tar.xz"))
       (sha256
        (base32
-        "1qpy6k9f06kpr6bxy26ncdxcszqv1skcncvczcvksgfncx1v3a0q"))))
+        "0jjzq5340qw3jm5gkajjkkb5wd0yqqy1dyjw3mf3jy15cakmazi9"))))
     (build-system gnu-build-system)
     (native-inputs `(("perl" ,perl)     ; for test.sh
                      ("which" ,(@ (gnu packages base) which))))
@@ -49,13 +49,6 @@
                    (lambda _
                      (substitute* '("unittest/test_hashutil.c" "test/suites/base.bash")
                        (("#!/bin/sh") (string-append "#!" (which "sh"))))
-                     #t))
-                 (add-before 'check 'munge-failing-test
-                   (lambda _
-                     ;; XXX The new ‘Multiple -fdebug-prefix-map’ test added in
-                     ;; 3.3.5 fails (why?).  Force it to report success instead.
-                     (substitute* "test/suites/debug_prefix_map.bash"
-                       (("grep \"name\"") "true"))
                      #t)))))
     (home-page "https://ccache.samba.org/")
     (synopsis "Compiler cache")