summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/grub.scm9
1 files changed, 0 insertions, 9 deletions
diff --git a/gnu/packages/grub.scm b/gnu/packages/grub.scm
index 866dfcfb25..317ed03573 100644
--- a/gnu/packages/grub.scm
+++ b/gnu/packages/grub.scm
@@ -84,12 +84,6 @@
                                        (assoc-ref inputs "mdadm")
                                        "/sbin/mdadm\"")))
 
-                     ;; Ditto for efibootmgr.
-                     (substitute* "grub-core/osdep/unix/platform.c"
-                       (("efibootmgr")
-                        (string-append (assoc-ref inputs "efibootmgr")
-                                       "/sbin/efibootmgr")))
-
                      ;; Make the font visible.
                      (copy-file (assoc-ref inputs "unifont") "unifont.bdf.gz")
                      (system* "gunzip" "unifont.bdf.gz")
@@ -104,9 +98,6 @@
     (inputs
      `(("gettext" ,gettext-minimal)
 
-       ;; For {U,}EFI.
-       ("efibootmgr" ,efibootmgr)
-
        ;; Depend on LVM2 for libdevmapper, used by 'grub-probe' and
        ;; 'grub-install' to recognize mapped devices (LUKS, etc.)
        ("lvm2" ,lvm2)