summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index f0599a95c6..8f12efb9eb 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -309,15 +309,19 @@ statistical profiler, a code coverage tool, and many other extensions.")
                  "ftp://ftp.clozure.com/pub/release/1.10/ccl-" version "-"
                  (match (%current-system)
                    ((or "i686-linux" "x86_64-linux") "linuxx86")
-                   ("armhf-linux" "linuxarm"))
+                   ("armhf-linux" "linuxarm")
+                   ;; Prevent errors when querying this package on unsupported
+                   ;; platforms, e.g. when running "guix package --search="
+                   (_ "UNSUPPORTED"))
                  ".tar.gz"))
            (sha256
             (base32
              (match (%current-system)
                ((or "i686-linux" "x86_64-linux")
                 "0mr653q5px05lr11z2mk551m5g47b4wq96vbfibpp0qlc9jp58lc")
-               ("armhf"
-                "1py02irpmi2qz5rq3h33wfv6impf15z8i2rign6hvhlqn7s99wwh"))))))))
+               ("armhf-linux"
+                "1py02irpmi2qz5rq3h33wfv6impf15z8i2rign6hvhlqn7s99wwh")
+               (_ ""))))))))
     (native-inputs
      `(("m4" ,m4)
        ("subversion" ,subversion)))