summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/elf.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 08d92532fa..fa1fb46aa4 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -90,13 +90,12 @@ Executable and Linkable Format (@dfn{ELF}).  This includes @command{ld},
              ;; variables passed as arguments.
              (let ((out (assoc-ref outputs "out")))
                (setenv "CONFIG_SHELL" (which "bash"))
-               (zero?
-                (system* "./configure"
-                         (string-append "--prefix=" out)
+               (invoke "./configure"
+                       (string-append "--prefix=" out)
                        ,@(if (string=? "aarch64-linux"
                                        (%current-system))
                              '("--host=aarch64-unknown-linux-gnu")
-                             '())))))))))
+                             '()))))))))
     (home-page "http://www.mr511.de/software/english.html")
     (synopsis "ELF object file access library")
     (description "Libelf is a C library to access ELF object files.")