summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 789eb8ab7d..42b5a097ae 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9990,9 +9990,9 @@ discovery, monitoring and configuration.")
            ;; The test runner invokes python2 and python3 for test*.py.
            ;; To avoid having both in inputs, we replicate it here.
            (lambda _
-             (every (lambda (test-file)
-                      (zero? (system* "python" test-file)))
-                    (find-files "tests" "^test.*\\.py$")))))))
+             (for-each (lambda (test-file) (invoke "python" test-file))
+                       (find-files "tests" "^test.*\\.py$"))
+             #t)))))
     (build-system python-build-system)
     (home-page "https://github.com/eea/odfpy")
     (synopsis "Python API and tools to manipulate OpenDocument files")