summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm9
-rw-r--r--gnu/packages/bdw-gc.scm12
-rw-r--r--gnu/packages/fontutils.scm6
-rw-r--r--gnu/packages/gnupg.scm4
-rw-r--r--gnu/packages/linux.scm2
-rw-r--r--gnu/packages/ncurses.scm20
-rw-r--r--gnu/packages/tls.scm1
7 files changed, 36 insertions, 18 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5adde6cc4a..88d9cdc21b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -112,20 +112,23 @@ usual file attributes can be checked for inconsistencies.")
 (define-public progress
   (package
     (name "progress")
-    (version "0.13")
+    (version "0.13.1")
     (source (origin
       (method url-fetch)
       (uri (string-append "https://github.com/Xfennec/"
                           name "/archive/v" version ".tar.gz"))
       (sha256
-       (base32 "133iar4vq5vlklydb4cyazjy6slmpbndrws474mg738bd8avc30n"))
+       (base32 "199rk6608q9m6l0fbjm0xl2w1c5krf8245dqnksdp4rqp7l9ak06"))
       (file-name (string-append name "-" version ".tar.gz"))))
     (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("which" ,which)))
     (inputs
      `(("ncurses" ,ncurses)))
     (arguments
      `(#:tests? #f ; There is no test suite.
-       #:make-flags (list "CC=gcc" "LDFLAGS+=-lncurses"
+       #:make-flags (list "CC=gcc"
                           (string-append "PREFIX=" (assoc-ref %outputs "out")))
        #:phases
        (modify-phases %standard-phases
diff --git a/gnu/packages/bdw-gc.scm b/gnu/packages/bdw-gc.scm
index 992a11bac0..dfcca45c18 100644
--- a/gnu/packages/bdw-gc.scm
+++ b/gnu/packages/bdw-gc.scm
@@ -27,14 +27,14 @@
 (define-public libgc-7.2
   (package
    (name "libgc")
-   (version "7.2f")
+   (version "7.2g")
    (source (origin
             (method url-fetch)
             (uri (string-append "http://www.hboehm.info/gc/gc_source/gc-"
                                 version ".tar.gz"))
             (sha256
              (base32
-              "119x7p1cqw40mpwj80xfq879l9m1dkc7vbc1f3bz3kvkf8bf6p16"))))
+              "0bvw6cc555qg5b7dgcqy3ryiw0wir79dqy0glff3hjmyy7i2jkjq"))))
    (build-system gnu-build-system)
    (arguments
     ;; Make it so that we don't rely on /proc.  This is especially useful in
@@ -67,7 +67,7 @@ C or C++ programs, though that is not its primary goal.")
 (define-public libatomic-ops
   (package
     (name "libatomic-ops")
-    (version "7.4.2")
+    (version "7.4.4")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -75,7 +75,7 @@ C or C++ programs, though that is not its primary goal.")
                     version ".tar.gz"))
               (sha256
                (base32
-                "1pdm0h1y7bgkczr8byg20r6bq15m5072cqm5pny4f9crc9gn3yh4"))))
+                "13vg5fqwil17zpf4hj4h8rh3blzmym693lkdjgvwpgni1mh0l8dz"))))
     (build-system gnu-build-system)
     (outputs '("out" "debug"))
     (synopsis "Accessing hardware atomic memory update operations")
@@ -91,14 +91,14 @@ lock-free code, experiment with thread programming paradigms, etc.")
 
 (define-public libgc
   (package (inherit libgc-7.2)
-    (version "7.4.2")
+    (version "7.6.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://www.hboehm.info/gc/gc_source/gc-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "18mg28rr6kwr5clc65k4l4hkyy4kd16amx831sjf8q2lqkbhlck3"))))
+                "143x7g0d0k6250ai6m2x3l4y352mzizi4wbgrmahxscv2aqjhjm1"))))
 
     ;; New dependencies.
     (native-inputs `(("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 60cff2e330..1ffb427529 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -46,13 +46,13 @@
 (define-public freetype
   (package
    (name "freetype")
-   (version "2.6.3")
+   (version "2.7")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://savannah/freetype/freetype-"
                                 version ".tar.bz2"))
             (sha256 (base32
-                     "18k3b026762lmyrxfil5xv8qwnvj7hc12gz9bjqzbb12lmx707ip"))))
+                     "0j3xgzn6pchgg1nm294vhx7cdicb7x3x8kwnlcm7v1alnzsm396n"))))
    (build-system gnu-build-system)
    (native-inputs
     `(("pkg-config" ,pkg-config)))
@@ -69,7 +69,7 @@ It supports both bitmap and scalable formats, including TrueType, OpenType,
 Type1, CID, CFF, Windows FON/FNT, X11 PCF, and others.  It supports high-speed
 anti-aliased glyph bitmap generation with 256 gray levels.")
    (license license:freetype)           ; some files have other licenses
-   (home-page "http://www.freetype.org/")))
+   (home-page "https://www.freetype.org/")))
 
 (define-public ttfautohint
   (package
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 0a6eba236c..b0e59532c5 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -54,7 +54,7 @@
 (define-public libgpg-error
   (package
     (name "libgpg-error")
-    (version "1.24")
+    (version "1.25")
     (source
      (origin
       (method url-fetch)
@@ -62,7 +62,7 @@
                           version ".tar.bz2"))
       (sha256
        (base32
-        "0h75sf1ngr750c3fjfn4583q7wz40qm63jhg8vjfdrbx936f2s4j"))))
+        "031jc5196fdcxn2g61i1pdabvdbxxcdi4j7jbaq3hfs38dcgfa7n"))))
     (build-system gnu-build-system)
     (home-page "https://gnupg.org")
     (synopsis "Library of error values for GnuPG components")
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e562213058..308be10dbd 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -472,7 +472,7 @@ providing the system administrator with some help in common tasks.")
                "static"))      ; >2 MiB of static .a libraries
     (arguments
      `(#:configure-flags (list "--disable-use-tty-group"
-
+                               "--enable-fs-paths-default=/run/current-system/profile/sbin"
                                ;; Install completions where our
                                ;; bash-completion package expects them.
                                (string-append "--with-bashcompletiondir="
diff --git a/gnu/packages/ncurses.scm b/gnu/packages/ncurses.scm
index e21e477f4f..81da864413 100644
--- a/gnu/packages/ncurses.scm
+++ b/gnu/packages/ncurses.scm
@@ -28,6 +28,7 @@
   #:use-module (guix build-system perl)
   #:use-module (gnu packages)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages swig))
 
 (define-public ncurses
@@ -70,7 +71,7 @@
             (let ((out (assoc-ref outputs "out")))
               ;; When building a wide-character (Unicode) build, create backward
               ;; compatibility links from the the "normal" libraries to the
-              ;; wide-character libraries (e.g. libncurses.so to libncursesw.so).
+              ;; wide-character ones (e.g. libncurses.so to libncursesw.so).
               (with-directory-excursion (string-append out "/lib")
                 (for-each (lambda (lib)
                             (define libw.a
@@ -83,6 +84,10 @@
                               (string-append "lib" lib ".so.6"))
                             (define lib.so
                               (string-append "lib" lib ".so"))
+                            (define packagew.pc
+                              (string-append lib "w.pc"))
+                            (define package.pc
+                              (string-append lib ".pc"))
 
                             (when (file-exists? libw.a)
                               (format #t "creating symlinks for `lib~a'~%" lib)
@@ -91,7 +96,11 @@
                               (false-if-exception (delete-file lib.so))
                               (call-with-output-file lib.so
                                 (lambda (p)
-                                  (format p "INPUT (-l~aw)~%" lib)))))
+                                  (format p "INPUT (-l~aw)~%" lib))))
+                            (with-directory-excursion "pkgconfig"
+                              (format #t "creating symlink for `~a'~%" package.pc)
+                              (when (file-exists? packagew.pc)
+                                (symlink packagew.pc package.pc))))
                           '("curses" "ncurses" "form" "panel" "menu")))))))
     (package
      (name "ncurses")
@@ -110,6 +119,11 @@
       `(#:configure-flags
         `("--with-shared" "--without-debug" "--enable-widec"
 
+          "--enable-pc-files"
+          ,(string-append "--with-pkg-config-libdir="
+                          (assoc-ref %outputs "out")
+                          "/lib/pkgconfig")
+
           ;; By default headers land in an `ncursesw' subdir, which is not
           ;; what users expect.
           ,(string-append "--includedir=" (assoc-ref %outputs "out")
@@ -130,6 +144,8 @@
                    (add-after 'unpack 'remove-unneeded-shebang
                      ,remove-shebang-phase))))
      (self-native-input? #t)                      ; for `tic'
+     (native-inputs
+      `(("pkg-config" ,pkg-config)))
      (native-search-paths
       (list (search-path-specification
              (variable "TERMINFO_DIRS")
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 74cc25bb67..bea15fa24d 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -294,7 +294,6 @@ required structures.")
                    (lib    (string-append out "/lib"))
                    (static (assoc-ref outputs "static"))
                    (slib   (string-append static "/lib")))
-              (mkdir-p slib)
               (for-each (lambda (file)
                           (install-file file slib)
                           (delete-file file))