summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cross-base.scm12
1 files changed, 0 insertions, 12 deletions
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index ae3ac210b7..b0eb7ab4ed 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -70,18 +70,6 @@
         `(cons ,(string-append "--target=" target)
                ,flags))))))
 
-(define (package-with-patches original patches)
-  "Return package ORIGINAL with PATCHES applied."
-  (package (inherit original)
-    (source (origin (inherit (package-source original))
-                    (patches patches)))))
-
-(define (package-with-extra-patches original patches)
-  "Return package ORIGINAL with all PATCHES appended to its list of patches."
-  (package-with-patches original
-                        (append (origin-patches (package-source original))
-                                patches)))
-
 (define (cross-binutils target)
   "Return a cross-Binutils for TARGET."
   (let ((binutils (package (inherit binutils)