summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/openssl.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/openssl.scm b/gnu/packages/openssl.scm
index ca72aa804e..438e76fd71 100644
--- a/gnu/packages/openssl.scm
+++ b/gnu/packages/openssl.scm
@@ -35,7 +35,7 @@
             (sha256 (base32
                      "1gjy6a7d8nszi9wq8jdzx3cffn0nss23h3cw2ywlw4cb9v6v77ia"))))
    (build-system gnu-build-system)
-   (inputs `(("perl" ,perl)))
+   (native-inputs `(("perl" ,perl)))
    (arguments
     '(#:parallel-build? #f
       #:parallel-tests? #f
@@ -52,8 +52,8 @@
                      (string-append "--prefix=" out)))))
        (alist-cons-before
         'patch-source-shebangs 'patch-tests
-        (lambda* (#:key inputs #:allow-other-keys)
-          (let ((bash (assoc-ref inputs "bash")))
+        (lambda* (#:key inputs native-inputs #:allow-other-keys)
+          (let ((bash (assoc-ref (or native-inputs inputs) "bash")))
             (substitute* (find-files "test" ".*")
               (("/bin/sh")
                (string-append bash "/bin/bash"))