summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d69c722de3..cd19462fa2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -875,7 +875,10 @@ password storage.")
     (license x11)))
 
 (define-public python2-keyring
-  (package-with-python2 python-keyring))
+  (let ((keyring (package-with-python2 python-keyring)))
+    (package (inherit keyring)
+      (inputs
+       `(("python2-pycrypto" ,python2-pycrypto))))))
 
 (define-public python-six
   (package