summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index cc57158d3c..4a381b6a1c 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -3110,14 +3110,15 @@ This is a part of the Apache Commons Project.")
                   (substitute* "lib/cpp/antlr/CharScanner.hpp"
                     (("#include <map>")
                      (string-append
-                       "#include <map>\n"
-                       "#define EOF (-1)\n"
-                       "#include <strings.h>")))
+                      "#include <map>\n"
+                      "#define EOF (-1)\n"
+                      "#include <strings.h>")))
                   (substitute* "configure"
-                    (("/bin/sh") "sh"))))))
+                    (("/bin/sh") "sh"))
+                  #t))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f
+     `(#:tests? #f ; no test target
        #:imported-modules ((guix build ant-build-system)
                            (guix build syscalls)
                            ,@%gnu-build-system-modules)