summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c8b3584a80..a2aebbd829 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5290,18 +5290,7 @@ falling into the Python interpreter.")
         (base32 "1mz26cxn4x8bbgv0rn0mvj2z05y31rkc8009nvdlb3lam5b4mj3y"))))
     (build-system python-build-system)
     (native-inputs
-     `(("unzip" ,unzip)))
-    (arguments
-     `(#:phases
-       (alist-replace
-        'unpack
-        (lambda* (#:key inputs outputs #:allow-other-keys)
-          (let ((unzip (string-append (assoc-ref inputs "unzip")
-                                      "/bin/unzip"))
-                (source (assoc-ref inputs "source")))
-            (and (zero? (system* unzip source))
-                 (chdir (string-append "testlib-" ,version)))))
-        %standard-phases)))
+     `(("unzip" ,unzip)))  ; for unpacking the source
     (synopsis "Python micro test suite harness")
     (description "A micro unittest suite harness for Python.")
     (home-page "https://github.com/trentm/testlib")