summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/sssd-curl-compat.patch18
-rw-r--r--gnu/packages/sssd.scm1
3 files changed, 20 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 3f59ee046f..a4507f5e99 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1156,6 +1156,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/soundconverter-remove-gconf-dependency.patch	\
   %D%/packages/patches/soundtouch-CVE-2018-14044-14045.patch 	\
   %D%/packages/patches/soundtouch-CVE-2018-1000223.patch 	\
+  %D%/packages/patches/sssd-curl-compat.patch 			\
   %D%/packages/patches/steghide-fixes.patch			\
   %D%/packages/patches/superlu-dist-scotchmetis.patch		\
   %D%/packages/patches/swig-guile-gc.patch			\
diff --git a/gnu/packages/patches/sssd-curl-compat.patch b/gnu/packages/patches/sssd-curl-compat.patch
new file mode 100644
index 0000000000..ecab737153
--- /dev/null
+++ b/gnu/packages/patches/sssd-curl-compat.patch
@@ -0,0 +1,18 @@
+Fix build with curl >= 7.62.  Patch taken from upstream:
+
+https://pagure.io/SSSD/sssd/c/4d3841ca379afc01184453ba45ab3e75ffec60da?branch=sssd-1-16
+
+diff --git a/src/util/tev_curl.c b/src/util/tev_curl.c
+index 6a7a580..d70a429 100644
+--- a/src/util/tev_curl.c
++++ b/src/util/tev_curl.c
+@@ -97,7 +97,9 @@ static errno_t curl_code2errno(CURLcode crv)
+         return ETIMEDOUT;
+     case CURLE_SSL_ISSUER_ERROR:
+     case CURLE_SSL_CACERT_BADFILE:
++#if LIBCURL_VERSION_NUM < 0x073e00
+     case CURLE_SSL_CACERT:
++#endif
+     case CURLE_SSL_CERTPROBLEM:
+         return ERR_INVALID_CERT;
+ 
diff --git a/gnu/packages/sssd.scm b/gnu/packages/sssd.scm
index 0ff94cdd24..75ce7c854b 100644
--- a/gnu/packages/sssd.scm
+++ b/gnu/packages/sssd.scm
@@ -86,6 +86,7 @@ fundamental object types for C.")
               (method url-fetch)
               (uri (string-append "http://releases.pagure.org/SSSD/sssd/"
                                   "sssd-" version ".tar.gz"))
+              (patches (search-patches "sssd-curl-compat.patch"))
               (sha256
                (base32
                 "032ppk57qs1lnvz7pb7lw9ldwm9i1yagh9fzgqgn6na3bg61ynzy"))))