summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnupg.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index d447007260..6e16429126 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -568,9 +568,9 @@ including tools for signing keys, keyring analysis, and party preparation.
    (license license:gpl2)
    (home-page "http://pgp-tools.alioth.debian.org/")))
 
-(define-public pinentry
+(define-public pinentry-gtk2
   (package
-    (name "pinentry")
+    (name "pinentry-gtk2")
     (version "0.9.7")
     (source (origin
               (method url-fetch)
@@ -595,6 +595,10 @@ including tools for signing keys, keyring analysis, and party preparation.
 enter a passphrase when `gpg' or `gpg2' is run and needs it.")
     (license license:gpl2+)))
 
+(define-public pinentry
+  (package (inherit pinentry-gtk2)
+    (name "pinentry")))
+
 (define-public paperkey
   (package
     (name "paperkey")