summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 0945bf5c1a..843b97d49f 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9709,3 +9709,23 @@ interactive behavior should be different.")
       (description "This package provides commands for increasing or
 decreasing the default font size in all GUI Emacs frames.")
       (license license:gpl3+))))
+
+(define-public emacs-visual-regexp
+  (package
+    (name "emacs-visual-regexp")
+    (version "1.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/benma/visual-regexp.el/archive/"
+                           "v" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1czmhvcivlcdyz7rfm0vd4a3xsgmy4qbvbl6yjxc217wrxqflr92"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/benma/visual-regexp.el/")
+    (synopsis "Regexp command with interactive visual feedback")
+    (description "This package provides an Emacs regexp command with
+interactive visual feedback.")
+    (license license:gpl3+)))