summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 21659a6429..568b6f41f7 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2310,11 +2310,11 @@ follows a traditional multi-track tape recorder control paradigm.")
          (modify-phases %standard-phases
            (add-after 'unpack 'remove-sse-flags
              (lambda* (#:key system #:allow-other-keys)
-               (when (not (or (string-prefix? "x86_64" system)
-                              (string-prefix? "i686" system)))
+               (unless (or (string-prefix? "x86_64" system)
+                              (string-prefix? "i686" system))
                      (substitute* "wscript"
-                       (("'-msse', '-mfpmath=sse', ") ""))
-                     #t))))
+                       (("'-msse', '-mfpmath=sse', ") "")))
+               #t)))
          #:tests? #f)) ; no tests
       (inputs
        `(("lv2" ,lv2)