summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index c57c6c6700..e7fbd6720a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -97,7 +97,7 @@
      '(#:phases
        (modify-phases %standard-phases
          (replace 'configure
-                  (lambda* (#:key inputs outputs #:allow-other-keys)
+                  (lambda* (#:key build inputs outputs #:allow-other-keys)
                     ;; This old `configure' script doesn't support
                     ;; variables passed as arguments.
                     (let ((out     (assoc-ref outputs "out"))
@@ -105,6 +105,7 @@
                       (setenv "CONFIG_SHELL" (which "bash"))
                       (zero? (system* "./configure"
                                       (string-append "--prefix=" out)
+                                      (string-append "--build=" build)
                                       (string-append "--with-ncurses="
                                                      ncurses)))))))))
     (home-page "http://aa-project.sourceforge.net/aalib/")