summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wget.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index 58a1a4b885..3673ad5cc4 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -52,9 +52,13 @@
                   (add-before 'check 'disable-https-tests
                     (lambda _
                       ;; XXX: Skip TLS tests, which fail with "The
-                      ;; certificate's owner does not match hostname" for
-                      ;; obscure reasons reported at:
-                      ;; <https://lists.gnu.org/archive/html/bug-wget/2017-06/msg00009.html>.
+                      ;; certificate's owner does not match hostname" as
+                      ;; reported at:
+                      ;; <https://lists.gnu.org/archive/html/bug-wget/2017-07/msg00012.html>.
+                      ;; The problem appears to be due to a change in GnuTLS
+                      ;; 3.5.12, whereby 'gnutls_x509_crt_check_hostname2' no
+                      ;; longer matches IP address against the 'CN' or
+                      ;; 'DNSname' fields of certificates.
                       (substitute* "testenv/Makefile"
                         (("SSL_TESTS=1") ""))
                       #t)))))