summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 89020648f0..c52bf72c8d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6483,7 +6483,15 @@ template functions.")
                 "0bk5bixl6rqa8znxghyp6zndbccx9kdyrymjahgyp6qsrp7rk144"))))
     (build-system go-build-system)
     (arguments
-     `(#:import-path "github.com/bmatcuk/doublestar"))
+     `(#:import-path "github.com/bmatcuk/doublestar"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'remove-incompatible-test
+           ;; This test fails with Go 1.16.
+           (lambda _
+             (substitute* "src/github.com/bmatcuk/doublestar/doublestar_test.go"
+               (("\\{\"a\\[\", \"a\", false, nil, false\\},.*")
+                "")))))))
     (home-page "https://github.com/bmatcuk/doublestar/")
     (synopsis "Path pattern matching and globbing supporting doublestar")
     (description "@code{doublestar} is a Go implementation of path pattern