summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/valgrind.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index 2a6e63a410..63524d59e9 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -111,8 +111,7 @@ also use Valgrind to build new tools.")
                        "valgrind-fix-default-debuginfo-path.patch"))))
    (inputs
     ;; GDB is needed to provide a sane default for `--db-command'.
-    `(("gdb" ,gdb)
-      ("glibc:debug" ,(canonical-package glibc) "debug")))
+    (list gdb `(,(canonical-package glibc) "debug")))
    (arguments
     (substitute-keyword-arguments (package-arguments valgrind)
       ((#:phases phases #~%standard-phases)
@@ -126,7 +125,7 @@ also use Valgrind to build new tools.")
                ;; TODO: Remove on the next rebuild cycle, when libc is not
                ;; longer fully stripped.
                (define libc-debug
-                 (string-append (assoc-ref inputs "glibc:debug")
+                 (string-append (ungexp (this-package-input "glibc") "debug")
                                 "/lib/debug"))
 
                (substitute* '("coregrind/m_debuginfo/readelf.c"