summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/sdcc.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/sdcc.scm b/gnu/packages/sdcc.scm
index aad2cf9e62..0ce71ed955 100644
--- a/gnu/packages/sdcc.scm
+++ b/gnu/packages/sdcc.scm
@@ -46,6 +46,8 @@
                '(begin
                   ;; Remove non-free source files
                   (delete-file-recursively "device/non-free")
+                  ;; Remove bundled μCsim source
+                  (delete-file-recursively "sim")
                   #t))
               (patches (search-patches "sdcc-disable-non-free-code.patch"))))
     (build-system gnu-build-system)
@@ -58,7 +60,7 @@
     (arguments
      `(;; gputils is required for PIC ports
        #:configure-flags
-       '("--disable-pic14-port" "--disable-pic16-port" "--enable-ucsim")
+       '("--disable-pic14-port" "--disable-pic16-port" "--disable-ucsim")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-makefile